Skip to main content

KiCad basics

Download#

Download: https://www.kicad-pcb.org/download

Flowchart#

Creating project#

  • KiCad project window -> File -> New -> Project
  • KiCad project window -> File -> New -> Project From Template

Schematic#

  • KiCad project window -> <project>.sch
  • File -> Page Settings
    • Size: A3
  • Place -> Hierarchical Sheet
  • View -> Show Hierarchical Navigator
  • Symbol(๋ถ€ํ’ˆ) -> ์˜ค๋ฅธ์ชฝ ํด๋ฆญ -> Properties -> Edit Footprint
  • Tools -> Annotate Schematic
  • Inspect -> Electrical Rules Checker

PCB#

  • KiCad project window -> <project>.kicad_pcb
  • Tools -> Update PCB from schematic
  • PCB ์ˆ˜์ •
  • Inspcet -> Design Rules Checker
  • File -> Plot
    • Generate Drill Files
    • Plot

Reference#

Last updated on